Thank you for playing
FINAL FANTASY BRAVE EXVIUS.

As previously announced, Intel-based Android devices will not be supported after version 3.7.0, following the introduction of 64-bit support.

Please rest assured users playing on non-Intel devices should not encounter any issues because of this upgrade.

However, we strongly recommend that your device meets the following requirements in order to ensure a smooth playing experience:

- 3 GB of RAM or above
- Android 5.0 or above

Please be aware that you may encounter issues when playing on devices that do not satisfy these requirements.

We thank you for your continued support and understanding.

- The FINAL FANTASY BRAVE EXVIUS Team