Version 5.2.5

Thank you for playing
FINAL FANTASY BRAVE EXVIUS.

The following updates have been made:

Features/Adjustments:
- Winter app icon will be displayed.
- Minimum version requirement has been updated.

As previously announced on 11/17, FINAL FANTASY BRAVE EXVIUS will be increasing the minimum firmware requirement to the following starting after maintenance 12/17 PST:

iOS - version 9.0 and above
Android - version 5.0 and above

We also strongly recommend Android players to maintain at least 3GB of free RAM (2GB for iOS) and 3GB of free disk space to ensure a smooth playing experience.

Please be aware that you may encounter issues when playing on devices that do not satisfy these requirements.

Bug Fixes:
- Fixed an issue in which abilities with a cooldown period were cooling down by two turns instead of one in a single turn.
- Fixed a display issue in which the incorrect EX level for Neo Vision units was displayed in some cases.
- The description on the ability details screen for Black Mage Arc's "Triple Black Magic" has been updated.

- The FINAL FANTASY BRAVE EXVIUS Team